Emulator:Demul

From Wah!ki
Jump to: navigation, search

**** THIS PAGE IS A WORK IN PROGRESS ****

Demul is not available natively for linux; it is also the only accelerated NAOMI // ATOMISWAVE emulator currently available, therefore we will look at the requirements for running the emulator under WINE

Demul // WINE

Dolphin Blue

Documentation of a successful run of the Demul 32bit emulator through a wine 32bit prefix. Refer to the test system configuration, other configuration results may vary.

Results

Not Yet Tested

  • DC/GDROM
  • Plugins not mentioned below

Not Working

  • Controller Configuration (dinput nor xinput work with controllers)
  • Fullscreen, switches to white screen
  • gpuOGLv3

Working

  • Controller Configuration (keyboard)
  • Atomiswave
  • Naomi
  • Windowed Resolutions 640x480 -> 1920x1080
  • Sound

Wine Configuration

Version 1.3.11

  • gpuDXLegacy plugin works without modification to the standard prefix
  • gpuDXv3 requires user to run winetricks directx9 to install directx9 libs

Version 1.2.1

  • errors with d3dx9_43.dll disables directx plugins

System Configuration

Test System 1

Demul Plugin Configuration

Demul Configuration

Version

Demul 0.5.6 32bit

Plugins

Video: gpuDXv3
Sound: spuDemul
GD-ROM: gdrDemul
Game Pad: padDemul
Net Play: netBlade

General

Sound Buffer: 4096 Resolutions up to 1920x1080 on test system. Program Defaults

64 Bit Systems - FGLRX Configuration

err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly

Method 1

To avoid the emulator wiping out the xserver when using either of the directx plugins, you need to load the correct 32bit libs. If they are not loaded you will receive feedback from wine stating direct rendering in not enabled.

You can check if the program is going to run correctly by loading it manual through the commandline

  1. Start a Terminal
  2. Type: wine C:\\emulators\demul\demu.exe
  3. Select Config->Plugins from the menus
  4. Check the terminal screen, if you dont see the above error the prefix is configured correctly

If you see the above error in your terminal window you will need to set the LIBGL_DRIVERS_PATH variable before execution.

This script will load the emulator correctly for fglrx users

#!/bin/sh
LIBGL_DRIVERS_PATH=/usr/lib32/fglrx/dri/
wine C:\\emulators\\demul\\demul.exe $@

Method 2

Create a symbolic link for the fglrx dri module to the location WINE requires. Doing so, negates the need for the above script

sudo ln -s /usr/lib32/fglrx/dri/fglrx.so /usr/lib32/dri

Screenshots

Video